SOLVED The item could not be indexed successfully because the item failed in the indexing subsystem

if you got an error like this

The item could not be indexed successfully because the item failed in the indexing subsystem. ( The item could not be indexed successfully because the item failed in the indexing subsystem.; Failed to recover content group; Aborting insert of item in Link Database because it was not inserted to the Search Index.; ; SearchID = 04081656-B51B-4DCD-96D4-6DB2D2CEEEE7 )
as well as these:
The item could not be indexed successfully because the item failed in the indexing subsystem. ( The item could not be indexed successfully because the item failed in the indexing subsystem.; Caught exception when preparing generation GID[7]: (Previous generation (last=GID[6], curr=GID[7]) is still active. Cannot open GID[7]); Aborting insert of item in Link Database because it was not inserted to the Search Index.; ; SearchID = 92EB0180-C086-4853-BED8-F4878D9748AD )
the solution for me was to clear configuration cache (PS) and then restart SP Search Services.

THX to my friend Team Leader Elitzur!!

Comments

  1. did you confirm the connection between the cache cleaning and solving the problem. I mean the problem is also sometimes solved by restarting the server. There are many stories on the internet, but none of them theoretically confirm why the solution solves the problem.

    ReplyDelete
  2. i cant really confirm anything, since i never took a look inside the SP search engine code, but i have had soooooo many cache related problems that i can confirm that they still dont know to fully update everything that is cached, up to a point that i had to delete the SSA, its DB, ect.

    ReplyDelete

Post a Comment

Popular posts from this blog

c# Service Play Sound with NAudio example by Moshe

JS/JQ simulate Enter event